PLEASE DISABLE YOUR ADBLOCK OR DNS BLOCKED FOR SUPPORT THIS SITE!

Blog Inspirasi Digital

Blog Inspirasi Digital

Tutorial Mikrotik, Hotspot, Blog, SEO, WEB 2.0, HTML, CSS, Javascript dan Inspirasi Digital

Script: Mengatasi Kesalahan Passthrough Pada Mangle Mikrotik

Script untuk mengatasi kesalahan passthrough pada mangle mikrotik dengan banyak rule.

note: pastikan kita mengerti kondisi mangle masing2, karena setiap setingan akan berbeda kondisi, disini saya berasumsi secara umum bahwa semua "mark-connection", "mark-routing" menggunakan passthrough=yes dan "mark-packet" menggunakan passthrough=no. Silahkan dicoba..



foreach mrk in=("packet","connection", "routing") do={
foreach i in=([/ip firewall mangle find where action=("mark-" . $mrk)]) do={
:if ($mrk = "packet") do={ 
local cmd ("ip firewall mangle set " . $i . " passthrough=no")
:execute $cmd
}
:if ($mrk = "connection") do={ 
local cmd ("ip firewall mangle set " . $i . " passthrough=yes")
:execute $cmd
}
:if ($mrk = "routing") do={ 
local cmd ("ip firewall mangle set " . $i . " passthrough=yes")
:execute $cmd
}
}
}

BERI KOMENTAR

Maaf untuk sementara waktu komentar di blog ini di nonaftifkan.

 

Back to Top