Blog Inspirasi Digital

Blog Inspirasi Digital

Tutorial Mikrotik, Hotspot, Blog, SEO, WEB 2.0, HTML, CSS, Javascript dan Inspirasi Digital

Cara Proteksi Halaman Modem dan Webfig Mikrotik menggunakan Internal Proxy

Trik ini untuk menampilkan bumbu pesan halaman buat yang mau coba2 usil masuk halaman modem atau webfig mikrotik biar greget dan berbeda, disini kita hanya memanfaatkan halaman error pada internal proxy mikrotik.

Syaratnya pastikan web proxy tidak digunakan dan sebaiknya IP service WWW 80 ganti ke port lain

Ok langsung aja ke tutorial:

IP MODEM = 192.168.1.1 (sesuaikan aja ip kearah modem)
IP WINBOX = 192.168.88.1 (sesuaikan aja ip kearah mikrotik)
IP PUBLIC = 36.80.82.61 (ip public nanti dapat otomatis ini hanya contoh)

1.Paste ini di new terminal
/ip firewall nat
add action=redirect chain=dstnat dst-address="36.80.82.61" disabled=no dst-port=80 protocol=tcp to-ports=3128 comment="Modem Protect"
add action=redirect chain=dstnat dst-address="192.168.1.1" disabled=no dst-port=80 protocol=tcp to-ports=3128
add action=redirect chain=dstnat dst-address="192.168.88.1" disabled=no dst-port=80 protocol=tcp to-ports=3128
/ip proxy 
set enabled=yes port=3128


2.Kemudian paste new terminal fungsinya untuk mendapatkan ip public
/system scheduler
add name=GET-IP-PUBLIC on-event="/tool fetch url=\"http://myip.dnsomatic.com/mypub\
    licip.txt\" mode=http\r\
    \n:local mypublicip [file get mypublicip.txt contents ]\r\
    \n/ip firewall nat set [find comment=\"Modem Protect\"] dst-address=\$mypu\
    blicip" policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon \
    start-time=startup


3.Untuk mengaktifkan halaman error html kita tinggal menekan tombol Reset HTML


4.jangan lupa akses ke proxy di blokir semua, kita bisa membuat pengecualian IP yang sudah di tentukan. di contoh ini saya menggunakan global


5.Edit halaman webproxy/error.html
disini diperlukan kemampuan basic html silahkan ubah sendiri ya :D


6.Kalo gak mau repot, download dulu error.html kemudian edit dan copas aja code dibawah ini ke halaman error.html

<!doctype html public "-//w3c//dtd html 3.2//en">
<html>
<head>
<title>protect and secure</title>
<style id='page-skin-1' type='text/css'>
body {
background-color: black;
color: green;
}
h1, h2, h3, h4, Ah5, h6{font-weight:700; font-family: 'open sans', helvetica, arial, sans-serif;font-size: 300%; color:#green}
</style>
</head>
<body bgcolor="#111111">
<table border="0" height="100%" width="100%">
<tr valign="middle">
<td align="center">
<table border="0">
<tr>
<td colspan="3">
<center><h1>[ protect and secure ]</h1></center>
</td>
</tr>
<tr>
<td width="20%">
</td>
<td>
<font face="tahoma,verdana,comic sans ms">
<br>
demi keamanan halaman ini diproteksi dan dijaga ketat oleh administrator jaringan</font>
</td>
<td width="20%">
</td>
</tr>
<tr>
<td width="20%">
</td>
<td>
<font face="tahoma,verdana,comic sans ms">
<br>
silahkan hubungi admin jaringan anda <a href="https://www.facebook.com/buananet.pangkalanbun">buananet</a> atau <a href="https://www.facebook.com/buananetmikrotik/">jasa setting mikrotik</a></font>
</td>
<td width="20%">
</td>
</tr>
</table>
</td>
</tr>
<tr valign="bottom">
<td>
<hr size="1">
<table width="100%" border="0">
<tr>
<td width="40%">
<font face="tahoma,verdana,comic sans ms">
contact: 08132829XXX<br />e-mail: XXXX@gmail.com
</font>
</td>
<td width="10%" align="center">
© copyright by buananet secure
</td>
</table>
</td>
</tr>
</table>
</body>
</html>


Saya gak bertanggung jawab kalo ada kesalahan, jadi silahkan berkreasi sendiri.

BERI KOMENTAR

Silahkan beri komentar dengan bijak dan sesuai dengan topik artikel :)
 

Back to Top