Blog Inspirasi Digital

Blog Inspirasi Digital

Tutorial Mikrotik, Hotspot, Blog, SEO, WEB 2.0, HTML, CSS, Javascript dan Inspirasi Digital

Blokir Situs dan IP Berdasarkan Keyword pada DNS Cache Mikrotik

Sudah mencoba script saya kemaren untuk blokir website melalui DNS static dengan script otomatis..sekarang dengan cara yang sama masih meminjam cache DNS tapi perbedaannya kali ini kita menyimpan hasil web dan ip yang sudah masuk filter akan kita simpan kedalam Address List.

Pastikan hanya menggunakan DNS Mikrotik:
/ip firewall nat
add action=redirect chain=dstnat comment=DNS dst-port=53 protocol=tcp to-ports=53
add action=redirect chain=dstnat dst-port=53 protocol=udp to-ports=53

Disini ada 2 pilihan cara blokir:

1.Block dengan cara drop di Filter rules
/ip firewall filter
add chain=forward dst-address-list=BLOCK_SITE action=drop

2. Block dengan cara redirect IP dan Port
/ip firewall nat
add action=dst-nat chain=dstnat comment="BLOCK WEBSITE" dst-address-list=
BLOCK_SITE dst-port=80,81,8181,443 protocol=tcp to-addresses=36.86.63.185 to-ports=80

Notes:
1. jangan langsung pasang pelajari dulu scripnya terutama untuk kata kunci (keyword) sebaiknya ubah dulu keywordnya sesuai Kebutuhan.
2. secara default website yang saya block saya arahkan ke internet postifi dengan ip 36.86.63.185 kalian bisa mengarahkan ke IP lain.
3. silahkan masukan di schedule mikrotik atau lewat script bebas saja dan sebaiknya time running jangan terlalu cepat saya pribadi set hanya di 10 menit
4. script ini sedikit makan resource jadi maaf untuk RB plastik (yang lama) sebaiknya atur waktu timing running sedikit lebih lama.
5. descripsi sudah saya buat lengkap maaf english saya belepotan :p semoga sukses...

##########################################################################
# By BuanaNET Secure
# fb.com/buananet.pangkalanbun
# Url Blocked From DNS Static
##########################################################################
# Find all entry on dns cache
:foreach iDNS in=[/ip dns cache all find where (name~"poker" || name~"porn" || name~"cheat" || name~"bokep" || name~"ngentot" || name~"qq.com" || name~"qq.net" || name~"qq.org" || name~"roulette" || name~"sbobet" || name~"casino" || name~"xvideos") && (type="A") ] do={
# find and filtering keyword and only find record for type A
# for keyword just add keyword || name~"KEYWORD") before && (type="A")
##########################################################################
:local tmpDNSsite [/ip dns cache get $iDNS name] ;
:local tmpDNSip [/ip dns cache get $iDNS address];
:local nameList "BLOCK_SITE";
# save to local cache by string
##########################################################################
delay delay-time=10ms
# wait for 10ms
##########################################################################
:if ( [/ip firewall address-list find where address=$tmpDNSip] = "") do={ 
# chek for no more duplicate site on cache
##########################################################################
:log warning ("Added site to block on dns: $tmpDNSsite : $tmpDNSip");
# show info on warning log
########################################################################## 
/ip firewall address-list add address=$tmpDNSip list=$nameList comment=$tmpDNSsite;
# add site to add list entry.
##########################################################################
}
}
# End Script 
##########################################################################

BERI KOMENTAR

Silahkan beri komentar dengan bijak dan sesuai dengan topik artikel :)
 

Back to Top