Blog Inspirasi Digital

Blog Inspirasi Digital

Tutorial Mikrotik, Hotspot, Blog, SEO, WEB 2.0, HTML, CSS, Javascript dan Inspirasi Digital

Cara Blokir website dengan DNS Static Mikrotik Berdasarkan Keyword

Cara Blokir situs dengan DNS static menggunakan script otomatis berdasarkan Keyword pilihan.

saya bingung buat judulnya tapi seperti itulah maksudnya 😁

Notes:
1. jangan langsung pasang pelajari dulu scripnya terutama untuk kata kunci (keyword) sebaiknya ubah dulu keywordnya karena di contoh saya masukan detik dan kompas
2. secara default website yang saya blog saya arahkan ke ip local 127.0.0.1 kalian bisa mgarahkan ke situs lain misalkan untuk ip internet poisitif di ip 36.86.63.185
3. Untuk TTL secara default selama 24jam (1d), tinggal rubah aja misalkan hanya 6 jam
4. silahkan masukan di shcedule mikrotik atau lewat script bebas saja dan sebaiknya time running jangan terlalu cepat saya pribadi set hanya 10 menit
5. script ini sedikit makan resource jadi maaf untuk 750 kebawah sebaiknya atur waktu timing running sedikit lebih lama.
6. descripsi sudah saya buat lengkap maaf english saya rada belepotan :p semoga sukses...

Pastikan hanya menggunakan DNS Mikrotik:
/ip firewall nat
add action=redirect chain=dstnat comment=DNS dst-port=53 protocol=tcp to-ports=53
add action=redirect chain=dstnat dst-port=53 protocol=udp to-ports=53
##########################################################################
# Scrypt by BuanaNET
# fb.com/buananet.pangkalanbun
# Url Blocked From DNS Static
##########################################################################
# Find all entry on dns cache
:foreach i in=[/ip dns cache all find where (name~"poker" || name~"porn" || name~"cheat" || name~"detik" || 
name~"kompas") && (type="A") ] do={
# find and filtering keyword and only find record for type A
# for keyword just add keyword || name~"KEYWORD") before && (type="A")
##########################################################################
:local tmpDNSsite [/ip dns cache get $i name];
:local tmpDNSip [/ip dns cache get $i address];
# save to local cache by string
##########################################################################
delay delay-time=10ms
# wait for 10ms
##########################################################################
:if ( [/ip dns static find where name=$tmpDNSsite ] = "") do={ 
# chek for no more duplicate site on cache
##########################################################################
:log warning ("Added site to block on dns: $tmpDNSsite : $tmpDNSip");
# show info on warning log
##########################################################################
/ip dns static add name=$tmpDNSsite address=127.0.0.1 ttl="1d 00:00:00" comment="Site Block for $tmpDNSsite : $tmpDNSip";
# add site to dns static entry if null
# you can change address=127.0.0.1 to another ip address or your bloked site info like Internet positif 36.86.63.185
# you can change for how long TTL time can bock for site
##########################################################################
}
}
# end script
##########################################################################

BERI KOMENTAR

Silahkan beri komentar dengan bijak dan sesuai dengan topik artikel :)
 

Back to Top