Blog Inspirasi Digital

Blog Inspirasi Digital

Tutorial Mikrotik, Hotspot, Blog, SEO, WEB 2.0, HTML, CSS, Javascript dan Inspirasi Digital

Script Mengamankan Protected Bootloader MikroTik

Cara kerja script ini simple namun cerdas, script ini akan memantau siapa saja yang berniat untuk mengaktifkan Mirotik Protected Bootloader maka akan langsung terdeteksi dan router secara otomatis akan langsung melakukan shutdown saat itu juga, ketika router di hidupkan kembali maka semua mengaturan Protected Bootloader akan dikembalikan ke pengaturan awal atau default, jadi apapun tindakan usil dari penyusup yang berniat jahat sebelumnya akan sia2 saja..

Seandainya setelah memasang script ini router shutdown sendiri jangan panik dulu, bisa saja script sedang bekerja dan mungkin saja artinya ada seseorang yang mencoba mengaktifkan bootloader di dalam router secara ilegal, jika memang bener, hal ini bisa dilihat dengan berubahnya window caption atau identity di winbox menjadi BOOTLOADER > Min: 00:00:20 - Max: 00:10:00 

Kenapa script ini harus mengganti indentitas atau caption di winbox? saya coba berpikir seandainya tombol reset dan netinstall tidak berfungsi setidaknya kita mengetahui berapa waktu untuk "reformat hold button" yang diperlukan dan berapa lama harus menekan tombol reset agar bisa bekerja.
Silahkan dimodifikasi, kalo mau bagus lagi kita bisa juga menambahakan informasi lainnya seperti kirim ke email atau ke telegram 🙂
#======================================================
# ANTI HACKER PROTECTED BOOTLOADER BY BUANANET SECURE!
#======================================================
# Set Local String
:local logprotectedrouterboot;
:local logreformatholdbutton;
:local logreformatholdbuttonmax;
# Set local Input
:set logprotectedrouterboot "$[/system routerboard setting get protected-routerboot]"
:set logreformatholdbutton "$[/system routerboard setting get reformat-hold-button]"
:set logreformatholdbuttonmax "$[/system routerboard setting get reformat-hold-button-max]"
# Cek jika Bootloader diubah ke Enable
:if ($logprotectedrouterboot ="enabled") do={
# Set info reformat hold button di Identity di winbox untuk jaga-jaga
/system identity set name="BOOTLOADER > Min:$logreformatholdbutton - Max:$logreformatholdbuttonmax"
# Kembalikan BootLoader Kepengaturan Awal
/system routerboard setting set auto-upgrade=no
/system routerboard setting set enable-jumper-reset=yes
/system routerboard setting set force-backup-boot=no
/system routerboard setting set silent-boot=no
/system routerboard setting set protected-routerboot disabled
/system routerboard setting set reformat-hold-button=20s
/system routerboard setting set reformat-hold-button-max=10m
/system routerboard reset-button set enabled=no
# tahan 5 detik
:delay 5s
# Shutdown mikrotik atau bisa gunakan /system reboot
/system shutdown
}

BERI KOMENTAR

Maaf untuk sementara waktu komentar di blog ini di nonaftifkan.

 

Back to Top